Experience Service Interruption

Incident Report for Ellucian Cloud

Resolved

Ellucian engineers have identified and resolved an issue impacting Experience. Normal system performance is restored, and engineers will monitor the service.
Posted Aug 04, 2025 - 14:20 EDT

Identified

Experience is currently experiencing service interruption in Canada region. Ellucian engineers are researching the issue and will provide further updates
Posted Aug 04, 2025 - 13:32 EDT
This incident affected: Ellucian SaaS (Ellucian Experience (CA)).