Ellucian CRM Major Release Notification: Ellucian CRM Advance 3.4 Prod
Scheduled for May 23, 22:00 EDT  -  May 27, 08:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 02, 2022 - 14:22 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 02, 2022 - 14:21 EDT
Scheduled
ELLUCIAN CLOUD SERVICES

Please be advised that there is an upcoming major release for Ellucian CRM Advance. This notification details the maintenance timeline and planned work.

TARGETED PROD MAJOR RELEASE WINDOW:
Ellucian CRM Advance Prod, 23 May 2022 - 26 May 2022
Your specific date and time will be shared directly with you via your Ellucian CRM distribution email following this message by EOD on 6 May 2022.

If you do not receive a direct email outlining your specific major release date and time, please contact your Customer Success Manager. If you are an implementing customer, please contact your Ellucian Project Manager.

RELEASE INFORMATION:
Launch preview may be found on Communities here:
https://ellucian.service-now.com/community?id=community_blog&sys_id=403408721bc7c550dd27eb12604bcb8f

Release notes can be found here:
https://resources.elluciancloud.com/bundle/crm_advance_rel_release_notes_d_advance/page/c_lnd_relnotes.html

Details about CRs found within this major release, may be found here:
https://ellucian.force.com/clients/s/releases/a118Y00000RT0cSQAT/crm-advance-34

USER ACCEPTANCE TESTING:
Given the flexibility to configure Ellucian CRM to fit your business needs it is expected that current business operations are tested after all Ellucian CRM major releases. The goal of the testing is to verify that current business operations are unimpeded. New feature functionality must be configured and may be configured after the major release.

Should you encounter issues after this major release, please contact Action Line. If you have any questions or concerns, please contact your Customer Success Manager. If you are currently implementing your Ellucian CRM solution, please contact your Project Manager.


Thank you,
Ellucian Cloud Team
Posted May 02, 2022 - 14:04 EDT
This scheduled maintenance affects: Ellucian SaaS (Ellucian Advance (APAC), Ellucian Advance).