Data Connect Service Interruption

Incident Report for Ellucian Cloud

Resolved

Ellucian engineers will continue to monitor and determine a root cause to prevent future recurrences of the issue.
Posted Jul 16, 2025 - 14:37 EDT

Monitoring

Ellucian engineers resolved an issue with Data Connect. Normal system performance was restored, and engineers will continue to monitor the service.
Posted Jul 16, 2025 - 13:45 EDT

Investigating

Data Connect is currently experiencing service interruption. Ellucian engineers are researching the issue and will provide further updates
Posted Jul 16, 2025 - 13:24 EDT
This incident affected: Ellucian Ethos Platform (Ethos Data Connect - U.S.).