Service Notification: Data Connect scheduled jobs and Insights refresh jobs

Incident Report for Ellucian Cloud

Resolved

The regions of CA, and EU are fully restored and schedules are triggering again.
Posted Feb 20, 2026 - 12:39 EST

Update

The Australia Pacific region is fully restored, and schedules are triggering on time again.
Team is currently applying the remaining fixes to the EU and CA regions.
Posted Feb 20, 2026 - 12:18 EST

Identified

Ellucian is aware of an issue impacting Data Connect scheduled jobs and Insights refresh jobs in the EU, AP, and CA regions.
Schedules created before February 13 may not trigger at their expected time. Schedules created after this date are not affected.
Our team is actively working to resolve the issue and restore normal scheduling behavior as quickly as possible. We will provide updates as more information becomes available.

Thank You,
Your Ellucian Team
Posted Feb 20, 2026 - 11:19 EST