Service Notification: Ellucian Insights

Incident Report for Ellucian Cloud

Resolved

Our infrastructure provider has rolled out fixes to all accounts in the US-East region, and Ellucian has confirmed recovery for transformation jobs across multiple customer accounts.  We will continue to monitor general health of transformation job statuses, and ask customers to please review any previously stuck scheduled transformation job runs

Thank You,
Your Ellucian Team
Posted Sep 16, 2026 - 21:03 EDT

Identified

Ellucian has observed partial recovery for stuck transformation jobs for a variety of customer accounts.  Infrastructure provider updates are currently being rolled out to all environments within the US-East region.  Ellucian will provide an update on the status of the provider rollout when we hear more.  In the meantime, we ask customers to review previously stuck Insights jobs for auto-recovery.

Thank You,
Your Ellucian Team
Posted Sep 16, 2026 - 19:59 EDT

Update

Ellucian is currently addressing an issue impacting Insights loads/refresh processing in the US-East region caused by an upstream infrastructure provider. Our engineering team is actively deploying a mitigation to restore normal job execution, and we will provide an update once processing has resumed.

Thank You,
Your Ellucian Team
Posted Sep 16, 2026 - 19:01 EDT

Update

Ellucian is currently addressing an issue impacting Insights loads/refresh processing in the US-East region caused by an upstream infrastructure provider. Our engineering team is actively deploying a mitigation to restore normal job execution, and we will provide an update once processing has resumed.

Thank You,
Your Ellucian Team
Posted Sep 16, 2026 - 18:29 EDT

Investigating

Ellucian is currently addressing an issue impacting Insights loads/refresh processing in the US-East region caused by an upstream infrastructure provider. Our engineering team is actively deploying a mitigation to restore normal job execution, and we will provide an update once processing has resumed.

Thank You,
Your Ellucian Team
Posted Sep 16, 2026 - 17:13 EDT
This incident affected: Ellucian SaaS (Ellucian Insights).