Ethos API calls - Intermittent slow performance

Incident Report for Ellucian Cloud

Resolved

Some customers experienced intermittent slow response times for Ethos API calls. Ellucian engineers investigated and confirmed that response times have recovered. We will continue to closely monitor the environment.
Posted Jan 12, 2026 - 18:26 EST

Update

Some customers are seeing intermittent slow response times for Ethos API calls. Ellucian engineers have seen improved responses time, we are continuing to investigate and will continue to provide updates on resolution.
Posted Jan 12, 2026 - 18:12 EST

Investigating

Some customers are seeing intermittent slow response times for Ethos API calls. Ellucian engineers are engaged and will provide updates on resolution.
Posted Jan 12, 2026 - 17:12 EST
This incident affected: Ellucian Ethos Platform (Ethos Data Connect - U.S., Ethos Integration - U.S.) and Ellucian SaaS (Ellucian Experience (U.S.), Ellucian Intelligent Learning Platform - United States/Canada/Latin America).