EIFS Identity Service Outage

Incident Report for Ellucian Cloud

Resolved

All services have been fully restored.
Posted Apr 06, 2025 - 07:55 EDT

Monitoring

Ellucian teams have restored Identity services and are monitoring the situation closely.
Posted Apr 06, 2025 - 07:49 EDT

Update

Ellucian engineers are continuing to work on restoring Identity services as soon as possible.
Posted Apr 06, 2025 - 06:38 EDT

Investigating

We’re currently experiencing a service interruption with our Identity system. Our engineering teams are actively investigating the issue and working to restore full functionality as quickly as possible.

Impact:
You may experience issues authenticating the applications which are federated through EIFS service.
Posted Apr 06, 2025 - 05:45 EDT
This incident affected: Ellucian Ethos Platform (Ethos Identity Federation Services - US/Canada).