ELLUCIAN ELEVATE (US) IS UNAVAILABLE

Incident Report for Ellucian Cloud

Resolved

Elevate issues are fully resolved. Service is now operating normally.
Posted 2 months ago. Jan 26, 2025 - 09:21 EST

Identified

The team has identified the issue and working on implementing the fix.
Posted 2 months ago. Jan 26, 2025 - 08:33 EST
This incident affected: Ellucian SaaS (Ellucian Elevate).