Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 23, 2023 - 08:00 EDT
Update
The maintenance update change has been incorporated into the major release window to minimize disruption during business hours.
Posted Oct 16, 2023 - 13:16 EDT
Scheduled
ELLUCIAN CLOUD SERVICES
Please be advised that there is an upcoming major release for Ellucian CRM Advance Production. This notification details the maintenance timeline and planned work.
Targeted Production Major Release Window:: CRM Advance Production 3.7, October 23-26, 2023 You will receive a separate communication regarding the Ellucian CRM Advance Production major release windows two weeks before the start of production.
Note: The Maintenance Update for CRM Advance production environments will be deployed concurrently with the Major Release for all customers.
Should you encounter issues after this major release, please contact Action Line. If you have any questions or concerns, please contact your Customer Success Manager. If you are currently implementing your Ellucian CRM solution, please contact your Project Manager.
Thank you,
Ellucian Cloud Team
Posted Sep 29, 2023 - 12:03 EDT
This scheduled maintenance affected: Ellucian SaaS (Ellucian Advance (APAC)).