ELLUCIAN INSIGHTS POPULATION JOBS INTERRUPTION

Incident Report for Ellucian Cloud

Update

Ellucian engineers are actively working to fully restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 23:02 EST

Update

Ellucian engineers are actively working to fully restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 22:00 EST

Update

Ellucian engineers are actively working to fully restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 21:00 EST

Update

Ellucian engineers are actively working to fully restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 20:00 EST

Update

Ellucian engineers are actively working to fully restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 19:04 EST

Update

Ellucian engineers are actively working to fully restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 18:02 EST

Update

Ellucian engineers are actively working to fully restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 17:03 EST

Update

Ellucian engineers are actively working to restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 16:00 EST

Update

Ellucian engineers are actively working to restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 14:59 EST

Update

Ellucian engineers are actively working to restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 13:54 EST

Update

Ellucian engineers are actively working to restore normal operation of population jobs. We will continue to share updates as progress is made.
Posted Nov 04, 2025 - 12:51 EST

Update

Ellucian engineers have identified the root cause of the issue and are actively working to restore normal operation of population jobs. We will continue to provide updates as progress is made.
Posted Nov 04, 2025 - 11:59 EST

Update

Ellucian engineers have identified the root cause of the issue and are actively working to restore normal operation of population jobs. We will continue to provide updates as progress is made.
Posted Nov 04, 2025 - 10:54 EST

Identified

Ellucian Insights is currently experiencing issues with population jobs. Ellucian engineers identified the issue, and taking remediation actions and will provide further updates.
Posted Nov 04, 2025 - 09:52 EST
This incident affects: Ellucian SaaS (Ellucian Insights).