Ellucian Experience card errors

Incident Report for Ellucian Cloud

Resolved

Ellucian engineers resolved an issue impacting cards. Normal system performance was restored, and engineers will continue to monitor the service.
Posted Jun 19, 2025 - 13:44 EDT

Update

Ellucian engineers are still working on full restoration of services. We will provide updates as we continue to make progress.
Posted Jun 19, 2025 - 13:01 EDT

Identified

Some Experience customers are intermittently encountering service disruptions when accessing cards. We are addressing the issue now. We expect services to be restored shortly.
Posted Jun 19, 2025 - 11:56 EDT
This incident affected: Ellucian Ethos Platform (Ethos Data Connect - U.S.) and Ellucian SaaS (Ellucian Experience (U.S.), Ellucian Experience (APAC), Ellucian Experience (CA), Ellucian Experience (EMEA)).