Experience performance issues have been resolved. Ellucian engineers have identified and remediated the root cause.
Posted Aug 18, 2025 - 15:53 EDT
Update
Ellucian engineers took action to improve Experience performance. The Application latency/response continues to recover, we are working to fully restore normal service. Additional updates to follow.
Posted Aug 18, 2025 - 14:53 EDT
Update
Ellucian engineers have taken remediation actions to address a performance issue in Experience. Application latency/response is improving and we continue working to fully restore normal service. Additional updates to follow.
Posted Aug 18, 2025 - 13:45 EDT
Update
Experience continues to experience degraded service. Ellucian engineers identified an issue, they are continuing to take remediation actions to restore normal service, and we will continue to post additional updates.
Posted Aug 18, 2025 - 12:50 EDT
Identified
Experience is currently experiencing degraded service. Ellucian engineers identified the issue, are taking remediation actions and will provide further updates.