Microsoft fixed the issue causing the Azure outage. At this time the Ellucian Student Financial Success line of products is back online.
Thank You, Your Ellucian Team
Posted Jul 23, 2026 - 16:48 EDT
Monitoring
Microsoft identified the issue causing the Azure outage and have begun resolution. At this time the Ellucian Student Financial Success line of products is back online. We will continue to monitor the situation to ensure full restoration of all services. Further updates as appropriate.
Thank You, Your Ellucian Team
Posted Jul 23, 2026 - 14:55 EDT
Update
Ellucian in aware of an issue affecting Student Financial Success line of products, Student Forms, Campus Communicator, Scholarship Universe, Student Advisor/Virtual Advisor, Campus Metrics and Auto Reconciliation for some customers that is related to an Azure outage, we're monitoring and working with Microsoft on a quick resolution on this incident. We will provide updates on this status page as more information becomes available.
Thank You, Your Ellucian Team
Posted Jul 23, 2026 - 14:13 EDT
Update
Ellucian in aware of an issue affecting Student Financial Success line of products, Student Forms, Campus Communicator, Scholarship Universe, Student Advisor/Virtual Advisor, Campus Metrics and Auto Reconciliation for some customers that is related to an Azure outage, we're monitoring and working with Microsoft on a quick resolution on this incident. We will provide updates on this status page as more information becomes available.
Thank You, Your Ellucian Team
Posted Jul 23, 2026 - 12:51 EDT
Identified
Ellucian is aware of an issue affecting Student Financial Success for some customers and is actively investigating. We will provide updates on this status page as more information becomes available.