Ellucian engineers resolved an issue impacting Experience cards. Normal system performance was restored and closely monitored overnight, engineers will continue to monitor the service.
Posted Dec 12, 2025 - 12:00 EST
Update
Ellucian engineers worked with our vendor partners to identify the issue impacting Experience cards not appearing in the dashboard for some users. Normal system performance was restored, and engineers will continue to monitor overnight.
Posted Dec 11, 2025 - 22:12 EST
Monitoring
Ellucian engineers worked with our vendor partners to identify the issue impacting Experience cards not appearing in the dashboard for some users. Small improvements have been seen, they continue to work on incremental improvements and they will continue to closely monitor overnight.
Posted Dec 11, 2025 - 17:31 EST
Identified
Ellucian engineers worked with our vendor partners to identify the issue and are working to develop a fix to resolve the issue where Experience cards do not appear in the dashboard for some users. We will continue to provide updates
Posted Dec 11, 2025 - 16:28 EST
Update
Ellucian engineers continue working to resolve the issue where Experience cards do not appear in the dashboard for some users. We are working with our vendor partners and will continue to provide updates.
Posted Dec 11, 2025 - 15:30 EST
Update
Ellucian engineers continue working to resolve the issue where Experience cards do not appear in the dashboard for some users. We will continue to provide updates.
Posted Dec 11, 2025 - 14:26 EST
Update
Ellucian engineers are working to resolve an issue where some users' Experience cards are not appearing in the dashboard and we will continue to provide updates.
Posted Dec 11, 2025 - 13:21 EST
Update
Some Experience customers have reported intermittent issues with some cards not appearing in the dashboard. Ellucian engineering teams are continuing to troubleshoot and will continue to provide updates.
Posted Dec 11, 2025 - 12:27 EST
Investigating
Some Experience customers have reported intermittent issues with some cards not showing in the dashboard. Ellucian engineering teams are engaged and will provide updates shortly.
Posted Dec 11, 2025 - 11:25 EST
This incident affected: Ellucian SaaS (Ellucian Experience (U.S.)).