Service Notification: Colleague SaaS / Web interfaces

Incident Report for Ellucian Cloud

Resolved

Ellucian Engineers have implemented the solution to this issue, and all production services have been restored.
Posted May 06, 2026 - 11:54 EDT

Update

Ellucian Engineers have implemented the solution to this issue and are currently validating the solution with impacted customers.
Posted May 06, 2026 - 11:48 EDT

Identified

Ellucian is aware that Colleague SaaS customers may be experiencing issues accessing the Self-Service, User Interface or Colleague Web API applications. Ellucian Engineers have identified a solution and are working towards implementing that solution. We will provide updates on this status page as more information becomes available.

Thank You,
Your Ellucian Team
Posted May 06, 2026 - 10:47 EDT
This incident affected: Ellucian SaaS (Ellucian Colleague SaaS).