Ellucian is aware of an issue reported by Microsoft that Azure Front Door experienced issues resulting in a loss of connectivity to some services. Microsoft updated that they took remediation actions to restore access to the Azure management portal, they continue to see signs of recovery as they route traffic through health nodes. They anticipate full mitigation within the next four hours. Ellucian will continue to monitor. Please submit a ticket if any additional issues are encountered. Microsoft will continue to provide updates via https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 16:28 EDT
Update
Ellucian is aware of an issue reported by Microsoft that Azure Front Door experienced issues resulting in a loss of connectivity to some services. Microsoft updated that they took remediation actions to restore access to the Azure management portal and they continue to see signs of recovery. Ellucian is monitoring and Microsoft is continuing to provide updates via https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 15:14 EDT
Update
- Ellucian is aware of an issue reported by Microsoft that Azure Front Door experienced issues resulting in a loss of connectivity to some services. Microsoft updated that they took remediation actions to restore access to the Azure management portal and they continue to see signs of recovery. Ellucian is monitoring and Microsoft is continuing to provide updates via https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 14:14 EDT
Monitoring
Ellucian is aware of an issue reported by Microsoft that Azure Front Door is experiencing issues resulting in a loss of connectivity to some services. Microsoft is providing updates via https://azure.status.microsoft/en-us/status.