Data Connect Pipelines Performance Degradation

Incident Report for Ellucian Cloud

Resolved

Ellucian engineers resolved an issue with Data Connect pipelines. Normal system performance was restored and engineers will continue to monitor the service.
Posted Jul 25, 2025 - 13:55 EDT

Monitoring

Ellucian engineers resolved an issue with Data Connect pipelines. Normal system performance was restored and engineers will continue to monitor the service.
Posted Jul 25, 2025 - 12:41 EDT

Investigating

Data Connect is currently experiencing issues with data pipelines connecting to external S3 buckets. Ellucian engineers are researching the issue and will provide further updates.
Posted Jul 25, 2025 - 11:53 EDT
This incident affected: Ellucian Ethos Platform (Ethos Data Connect - U.S.).