Service Notification: An outage for all Elevate in Canada customers

Incident Report for Ellucian Cloud

Resolved

Ellucian Cloud rebuilt the web tier to recover the environment and restore the affected instances to a running state and will continue to monitor the instances.

Thank You,
Your Ellucian Team
Posted Mar 14, 2026 - 10:43 EDT

Update

Ellucian is aware of an ongoing Elevate outage impacting our Canada customers and certain services. Our teams are actively investigating the issue. We will continue to provide updates on this status page as additional information becomes available.

Thank You,
Your Ellucian Team
Posted Mar 14, 2026 - 09:39 EDT

Investigating

Ellucian is aware of an ongoing Elevate outage impacting our Canada customers and certain services. Our teams are actively investigating the issue. We will continue to provide updates on this status page as additional information becomes available.

Thank You,
Your Ellucian Team
Posted Mar 14, 2026 - 08:36 EDT
This incident affected: Ellucian SaaS (Ellucian Elevate).