Ellucian has resolved an issue affecting Ellucian Insights and Ellucian Intelligent Processes (EIP) for some customers. The service is operating as expected, and we will continue to monitor.
Thank You, Your Ellucian Team
Posted Sep 02, 2026 - 13:30 EDT
Monitoring
Ellucian identified an issue with Ellucian Insights and Ellucian Intelligent Processes (EIP) affecting multiple customers. A fix has been deployed to production and we are observing vastly improved performance across both systems. We will continue to monitor the environment to ensure the issue has been fully resolved.
Thank You, Your Ellucian Team
Posted Sep 02, 2026 - 12:50 EDT
Update
Ellucian continues to investigate an issue affecting Ellucian Insights for some customers. Updates will continue to be provided on this status page.
Thank You, Your Ellucian Team
Posted Sep 02, 2026 - 12:08 EDT
Investigating
Ellucian is aware of an issue affecting Ellucian Insights for some customers and is actively investigating. We will provide updates on this status page as more information becomes available.