Service Notification: Ellucian Insights

Incident Report for Ellucian Cloud

Resolved

Mitigation strategies have been applied and Insights' transformation jobs are now completing within expected timeframes. Ellucian is continuing to monitor transformation execution.

Thank You,
Your Ellucian Team
Posted Aug 06, 2026 - 16:01 EDT

Update

Ellucian is monitoring transformation jobs' performance improvements. Jobs are still processing, but at a slower pace. Cancelling and resubmitting jobs is not necessary and will not resolve the current issue. For regularly scheduled jobs, you may cancel any stuck jobs and allow the next scheduled run to proceed.

Thank You,
Your Ellucian Team
Posted Aug 06, 2026 - 15:42 EDT

Update

Ellucian is continuing to investigate cases created over 8/5-8/6, and rolled out mitigation measures to the Insights environment. We are monitoring transformation jobs' performance improvements. Customers may still be experiencing latency with transformation job status responses. Cancelling and resubmitting jobs is not necessary and will not resolve the current issue. For regularly scheduled jobs, you may cancel any stuck jobs and allow the next scheduled run to proceed.

Thank You,
Your Ellucian Team
Posted Aug 06, 2026 - 14:13 EDT

Update

Ellucian is continuing to investigate cases created over 8/5-8/6, and rolled out mitigation measures to the Insights environment. We are monitoring transformation jobs' performance improvements. Customers may still be experiencing latency with transformation job status responses.

Thank You,
Your Ellucian Team
Posted Aug 06, 2026 - 13:25 EDT

Update

Ellucian is continuing to investigate cases created over 8/5-8/6, and has rolled out mitigation steps via service scaling, which the team is continuing to monitor impact on job throughput. Customers may still be experiencing latency with transformation job status responses.

Thank You,
Your Ellucian Team
Posted Aug 06, 2026 - 12:10 EDT

Update

Ellucian is continuing to investigate cases created over 8/5-8/6, and is actively rolling out mitigation steps to the Insights environments over the next hour.  Customers may still be experiencing latency with transformation job status responses.

Thank You,
Your Ellucian Team
Posted Aug 06, 2026 - 11:23 EDT

Update

Ellucian is continuing to investigate cases created over 8/5-8/6, and actively developing & deploying mitigation steps to stabilize Insights.

Thank You,
Your Ellucian Team
Posted Aug 06, 2026 - 10:26 EDT

Investigating

Ellucian is investigating the cases created over 8/5-8/6 regarding long running transformation jobs and will post an update shortly

Thank You,
Your Ellucian Team
Posted Aug 06, 2026 - 09:19 EDT
This incident affected: Ellucian SaaS (Ellucian Insights).