Service Notification: AWS Middle East region power issues

Incident Report for Ellucian Cloud

Resolved

Ellucian continues to work with AWS as we recover from the recent AWS outage that impacted our Middle East customers and certain services. Impact is now limited, and we will communicate directly with the small number of customers still affected moving forward. There will be no further updates for this incident on the Status Page.
Posted Mar 05, 2026 - 17:00 EST

Update

Ellucian continues to work with AWS as we recover from the recent AWS outage that impacted our Middle East customers and certain services. Impact is now limited, and we will communicate directly with the small number of customers still affected moving forward.

For additional assistance, please contact Ellucian Support through the Customer Center.
No components were marked as affected by this incident.
Posted Mar 04, 2026 - 14:09 EST

Update

Ellucian continues to work with AWS as we recover from the recent AWS outage that impacted our Middle East customers and certain services. Impact is now limited, and we will communicate directly with the small number of customers still affected moving forward.

For additional assistance, please contact Ellucian Support through the Customer Center.
Posted Mar 03, 2026 - 13:10 EST

Update

Ellucian continues to work with AWS to restore affected services outside of the impacted Middle East Region, and this work remains in progress.

We will provide the next update at 02:00 PM US Eastern Time, or sooner if there is a significant change in status.
Posted Mar 03, 2026 - 10:58 EST

Update

Ellucian continues to work with AWS to restore affected services outside of the impacted Middle East Region, and this work remains in progress.

We will provide the next update at 11:00 AM US Eastern Time, or sooner if there is a significant change in status.
Posted Mar 03, 2026 - 08:10 EST

Update

Ellucian continues to work with AWS to restore affected services outside of the impacted Middle East Region, and this work remains in progress.

We will provide the next update at 08:00 AM US Eastern Time, or sooner if there is a significant change in status.
Posted Mar 03, 2026 - 06:04 EST

Update

Ellucian continues to work with AWS to restore affected services outside of the impacted Middle East Region, and this work remains in progress.

We will provide the next update at 06:00 AM US Eastern Time, or sooner if there is a significant change in status.
Posted Mar 03, 2026 - 03:01 EST

Update

Ellucian continues to work with AWS to restore affected services outside of the impacted Middle East Region, and this work remains in progress.

We will provide the next update at 03:00 AM US Eastern Time, or sooner if there is a significant change in status.
Posted Mar 03, 2026 - 00:05 EST

Update

Ellucian continues to work with AWS to restore affected services outside of the impacted Middle East Region, and this work remains in progress.

We will provide the next update at 12:00 AM US Eastern Time, or sooner if there is a significant change in status.
Posted Mar 02, 2026 - 21:25 EST

Update

Ellucian continues to work with AWS to restore affected services outside of the impacted Middle East Region, and this work remains in progress.

We will provide the next update sooner if there is a significant change in status.
Posted Mar 02, 2026 - 21:10 EST

Update

Ellucian continues to work with AWS to restore affected services outside of the impacted Middle East Region, and this work remains in progress.

We will provide the next update at 9:00 PM US Eastern Time, or sooner if there is a significant change in status.
Posted Mar 02, 2026 - 18:00 EST

Update

Ellucian continues to work with AWS to restore affected services outside of the impacted Middle East Region, and this work remains in progress.

We will provide the next update at 6:00 PM US Eastern Time, or sooner if there is a significant change in status.
Posted Mar 02, 2026 - 15:03 EST

Update

We are aware of issues impacting AWS in the Middle East Region, and are working directly with affected Ellucian customers to restore service.

Ellucian is actively collaborating with AWS to restore affected services outside of the impacted Middle East Region, and this work remains in progress.

We will provide the next update at 3:00 PM US Eastern Time, or sooner if there is a significant change in status.
Posted Mar 02, 2026 - 12:01 EST

Update

AWS reported loss of power in one availability zone in the Middle East Region yesterday. Earlier today, AWS reported loss of power in a second AZ, which has impacted services in the third remaining AZ. Ellucian is working with AWS to restore those services outside of the impacted Middle East Region.
Posted Mar 02, 2026 - 11:02 EST

Update

AWS reported loss of power in one availability zone in the Middle East Region yesterday. A few hours ago AWS reported loss of power in a second AZ, which has impacted services in the third remaining AZ. Ellucian is working with AWS to restore those services outside of the impacted Middle East Region.
Posted Mar 02, 2026 - 10:01 EST

Update

AWS reported loss of power in one availability zone in the Middle East Region yesterday. A few hours ago AWS reported loss of power in a second AZ, which has impacted services in the third remaining AZ. Ellucian is working with AWS to restore those services outside of the impacted Middle East Region.
Posted Mar 02, 2026 - 09:02 EST

Update

AWS reported loss of power in one availability zone in the Middle East Region yesterday. A few hours ago AWS reported loss of power in a second AZ, which has impacted services in the third remaining AZ. Ellucian is working with AWS to restore those services outside of the impacted Middle East Region.
Posted Mar 02, 2026 - 08:04 EST

Update

AWS reported loss of power in one availability zone in the Middle East Region yesterday. A few hours ago AWS reported loss of power in a second AZ, which has impacted services in the third remaining AZ. Ellucian is working with AWS to restore those services outside of the impacted Middle East Region.
Posted Mar 02, 2026 - 08:01 EST

Update

AWS reported loss of power in one availability zone yesterday. A few hours ago AWS reported loss of power in a second AZ, which has impacted services in the third remaining AZ. Ellucian is working with AWS to restore services outside of the impacted region in UAE.
Posted Mar 02, 2026 - 07:04 EST

Update

We are continuing to monitor for any further issues.
Posted Mar 01, 2026 - 22:41 EST

Monitoring

We have completed validation of the environments hosted in the Middle East region, and all systems are currently operating as expected. We will continue to monitor the situation closely. If you encounter any issues with your specific environment, please open a support case, and our team will promptly investigate.

Thank You,
Your Ellucian Team
Posted Mar 01, 2026 - 10:51 EST

Update

We are continuing to investigate this issue.
Posted Mar 01, 2026 - 10:49 EST

Investigating

Ellucian is aware of an ongoing AWS outage impacting our Middle East customers and certain services. Our teams are actively investigating the issue. We will continue to provide updates on this status page as additional information becomes available.

Thank You,
Your Ellucian Team
Posted Mar 01, 2026 - 10:08 EST