Service Notification: Ellucian Insights

Incident Report for Ellucian Cloud

Resolved

The short-term mitigations have been validated and operations are validated as returning to stable function. The team will continue to monitor the overall health of our core services over the remainder of this week.

Thank You,
Your Ellucian Team
Posted Aug 05, 2026 - 19:51 EDT

Update

Ellucian continues to monitor short term remediations and continues to work to improve system stability.


Thank You,
Your Ellucian Team
Posted Aug 05, 2026 - 18:22 EDT

Update

Ellucian continues to monitor short term remediations and continues to work to improve system stability.


Thank You,
Your Ellucian Team
Posted Aug 05, 2026 - 17:20 EDT

Update

Ellucian continues to monitor short term remediations and continues to work to improve system stability.

Thank You,
Your Ellucian Team
Posted Aug 05, 2026 - 16:16 EDT

Identified

Ellucian has identified a narrowed list of root causes for the performance degradation in production, and has deployed short-term mitigation measures to partially restore stability. The team is monitoring the Insights platform and developing root fixes to the application performance issues. Customers may still experience latency as the team explores other short-term mitigation measures.

Thank You,
Your Ellucian Team
Posted Aug 05, 2026 - 15:25 EDT

Investigating

We're investigating performance issues affecting the Insights platform. Customers may experience delays running population jobs, ingesting data, and executing Insights - related Data Connect pipeline runs. Our team is actively working to restore normal performance. We'll provide updates as we progress.

Thank You,
Your Ellucian Team
Posted Aug 05, 2026 - 14:10 EDT
This incident affected: Ellucian SaaS (Ellucian Insights).