Ellucian Experience Degraded Performance

Incident Report for Ellucian Cloud

Resolved

The intermittent latency issues have been fully resolved and Experience is fully operational.
Posted Aug 19, 2025 - 12:47 EDT

Investigating

Ellucian Experience is currently showing intermittent latency issues for North American customers. Engineering teams are fully engaged on improving performance.
Posted Aug 19, 2025 - 11:49 EDT
This incident affected: Ellucian SaaS (Ellucian Experience (U.S.)).