Issues with authentication

Incident Report for Ellucian Cloud

Resolved

The authentication issues have been resolved.
Posted Oct 14, 2025 - 22:19 EDT

Update

We are continuing to investigate this issue.
Posted Oct 14, 2025 - 22:17 EDT

Investigating

Some users are experiencing issues logging in. Ellucian engineers are engaged in troubleshooting.
Posted Oct 14, 2025 - 21:43 EDT
This incident affected: Ellucian SaaS (Ellucian Experience (CA)).