Service Notification: Person Manager

Incident Report for Ellucian Cloud

Resolved

Ellucian has resolved an issue affecting Person Manager for some customers with intermittent performance issues. The service is operating as expected, and we will continue to monitor.

Thank You,
Your Ellucian Team
Posted Feb 19, 2026 - 14:30 EST

Update

Ellucian is aware of an issue affecting Person Manager causing intermittent performance issues for some customers. We are continuing to investigate. We will provide updates on this status page as more information becomes available.

Thank You,
Your Ellucian Team
Posted Feb 19, 2026 - 13:32 EST

Update

Ellucian continues to investigate an issue affecting Person Manager causing intermittent performance issues for some customers. Updates will continue to be provided on this status page.

Thank You,
Your Ellucian Team
Posted Feb 19, 2026 - 12:30 EST

Investigating

Ellucian is aware of an issue affecting Person Manager for some customers with intermittent performance issues and is actively investigating. We will provide updates on this status page as more information becomes available.

Thank You,
Your Ellucian Team
Posted Feb 19, 2026 - 11:33 EST