Errors with cards in Ellucian Experience

Incident Report for Ellucian Cloud

Resolved

The Experience card issues have been resolved in all regions. Please contact our support teams if you see any additional issues.
Posted May 22, 2025 - 09:25 EDT

Identified

Ellucian has resolved the issues in EU and US regions. We will send further updates when all regions are fully restored.
Posted May 22, 2025 - 09:05 EDT

Investigating

Some customers are seeing errors with cards in Ellucian Experience. We are actively working on a resolution to restore full functionality as soon as possible. We will continue to provide updates as we make progress.
Posted May 22, 2025 - 08:03 EDT
This incident affected: Ellucian SaaS (Ellucian Experience (U.S.), Ellucian Experience (APAC), Ellucian Experience (CA), Ellucian Experience (EMEA)).