Ellucian has resolved an issue affecting email and workflows in Advance, Advise and Recruit for some customers. The service is operating as expected, and we will continue to monitor.
Thank You, Your Ellucian Team
Posted May 15, 2026 - 02:14 EDT
Update
Ellucian continues to investigate an issue partially impacting email and workflows in Advance, Advise and Recruit for some customers. A support case has been submitted to Microsoft, they are currently investigating possible issues within the Exchange Online environment. Updates will continue to be provided on this status page.
Thank You, Your Ellucian Team
Posted May 14, 2026 - 19:36 EDT
Update
Ellucian continues to investigate an issue partially impacting email and workflows in Advance, Advise and Recruit for some customers. A support case has been submitted to Microsoft, they are currently investigating possible issues within the Exchange Online environment. Updates will continue to be provided on this status page.
Posted May 14, 2026 - 18:26 EDT
Identified
Ellucian continues to investigate an issue partially impacting email and workflows in Advance, Advise and Recruit for some customers. Updates will continue to be provided on this status page.
Thank You, Your Ellucian Team
Posted May 14, 2026 - 17:00 EDT
Update
Ellucian is aware of an issue partially impacting email and workflows in Advance, Advise and Recruit for some customers and is actively investigating. We will continue to provide updates on this status page as more information becomes available.
Posted May 14, 2026 - 16:05 EDT
Update
Ellucian is aware of an issue partially impacting email and workflows in Advance, Advise and Recruit for some customers and is actively investigating. We will continue to provide updates on this status page as more information becomes available.
Posted May 14, 2026 - 15:16 EDT
Update
Ellucian is aware of an issue partially impacting email and workflows in Advance, Advise and Recruit for some customers and is actively investigating. We will continue to provide updates on this status page as more information becomes available.
Posted May 14, 2026 - 14:02 EDT
Update
Ellucian continues to investigate an issue partially impacting email and workflows in Advance, Advise and Recruit for some customers and is actively investigating. We will provide updates on this status page as more information becomes available.
Thank You, Your Ellucian Team
Posted May 14, 2026 - 13:02 EDT
Update
We are continuing to investigate this issue.
Posted May 14, 2026 - 12:22 EDT
Investigating
Ellucian is aware of an issue partially impacting email and workflows in Advance, Advise and Recruit for some customers and is actively investigating. We will provide updates on this status page as more information becomes available.