We closely monitored the widespread issue that Cloudflare was experiencing today. While we are unaware of any impacts to Ellucian SaaS or Cloud systems, it was possible that you may have experienced some intermittent issues until Cloudflare resolved the issue. Cloudflare updated that they implemented a fix and presently Cloudflare services are operating normally, they are no longer observing elevated errors or latency across the network. If you have any issues please submit a case to support. Thank you.
Posted Nov 18, 2025 - 13:00 EST
Update
We are aware of the widespread issue that Cloudflare is experiencing. While we are unaware of any current impact to Ellucian SaaS or Cloud systems, it is possible that you will experience intermittent issues until the Cloudflare issue is resolved. Cloudflare updated that they implemented a fix, they continue to see improvement in errors and latency but still have reports of intermittent errors. They are looking for ways to accelerate their full recovery. The Ellucian team continues to monitor the situation as it improves.
Posted Nov 18, 2025 - 11:59 EST
Update
We are aware of the widespread issue that Cloudflare is experiencing. While we are unaware of any current impact to Ellucian SaaS or Cloud systems, it is possible that you will experience intermittent issues until the Cloudflare issue is resolved. Cloudflare updated that they implemented a fix and are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 10:42 EST
Monitoring
We are aware of the widespread issue that CloudFlare is experiencing. While we are unaware of any current impact to Ellucian SaaS or Cloud systems, it is possible that you will experience intermittent issues until the CloudFlare issue is resolved.